KORG FORUM


Startseite » Korg » KORG PC/MAC Tools » Kommunikationsproblem mit nanoPAD2 + nanoKONTRL2
Anzeigen: Heutige Beiträge :: Abstimmungen anzeigen :: Beitragsnavigator
Zur Baumansicht dieses Themas wechseln Ein neues Thema erstellen Antwort abschicken
Kommunikationsproblem mit nanoPAD2 + nanoKONTRL2 [Beitrag #62349] Do, 06 Juli 2017 14:32 Zum nächsten Beitrag gehen
Flyer ist gerade offline  Flyer
Beiträge: 3
Registriert: Juli 2017
Newbie-Member

Hallo liebe User,
ich habe das folgende Problem mit nanoKONTROL2 u. nanoPAD2. Win10-Treiber installieren sich immer, bevor ich die regulären Treiber für Win10 von Korg installieren kann. So werden beide Geräte zwar von Cubase (EL9) erkannt u. die Regler reagieren auch. Aber die Geräte kommunizieren nicht mit dem Kontrol Editor (Meldung z.B. beim nanoPAD immer: "Unsupported MIDI device"). Ich kann "Show only connected devices" nicht anwählen u. bei manuellem select werden in der Maske der nanoKONTROL2 nicht alle Bedienelemente als programmierbar dargestellt. Habe die aktuellste Software, inkl. Treiber, von der Korg-Support Seite. Wie bekomme ich nun die Windows eigenen Treiber außer Gefecht gesetzt, um die Korg-Treiber zu installieren (Ich denke, dass es daran liegt)? Habe ansonsten eigentlich schon alles an Lösungsvorschlägen durchprobiert, was in diesem und anderen Foren angeboten wurde. Bisher ohne Erfolg Sad

MlG Dieter
Aw: Kommunikationsproblem mit nanoPAD2 + nanoKONTRL2 [Beitrag #62353 ist eine Antwort auf Beitrag #62349] Do, 06 Juli 2017 16:53 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Alex@KORG ist gerade offline  Alex@KORG
Beiträge: 2898
Registriert: November 2006
Ort: Marburg
Master of Music-Member
Hi Dieter,

Bei Deinem Windows System könnte möglicherweise ein Windows spezifisches Problem bei der Inbetriebnahme des Midi-Gerätes aufgetreten sein. Die Ursache für das Problem bezieht sich auf die in der Windows Registry hinterlegten Midi-Device-Einträge. Übersteigt die Anzahl der Einträge die Grenze von 10 Midi Geräteeinträgen, so übermittelt das Windows System die Geräteangaben zu den Midi-Geräten größer 10 nicht mehr an die gestarteten Midi-Applikationen. Aus diesem Grunde verhalten sich dann die Midi-Applikationen so, als wäre das verwendete Midi-Gerät nicht am Computer aktiv, obwohl Dir das Midi-Gerät im Windows Gerätemanager als USB-Midi-Device fehlerfrei angezeigt wird.

Im ersten Schritt solltest Du Dir HIER das aktuelle KORG USB MIDI TREIBER Tool herunterladen und auf dem Rechner installieren.

Verbinde dann die KORG USB MIDI Schnittstelle Deiner KORG Hardware mit einem maximal 2 Meter langen USB Kabel mit dem USB Port Deines Computers und prüfe, ob Deine KORG Hardware eingeschaltet ist.

Da ich aus der Ferne ohne nähere Angaben nicht beurteilen können, ob das o.g. Phänomen auch auf Deinem Windows System auftritt, bitte ich Dich einmal über START -> ALLE PROGRAMME -> im Verzeichnis KORG -> das Unterverzeichnis KORG USB MIDI DRIVER TOOLS zu öffnen -> und in der Liste der KORG Tools das Tool UNINSTALL KORG USB MIDI DEVICE zu starten. Bei Windows7 / 8 / 10 und Windows Vista Systemen musst Du noch ggf. eine Administrator-Meldung mit ZULASSEN bestätigen und dann im nachfolgenden Fenster den Button NEXT bestätigen. Es erscheint dann im Monitor ein Fenster, in dem Dir die Zeilen midi-0 bis midi-9 angezeigt werden. Hier werden auch die angeschlossenen oder in der Hardware des Rechners integrierten Audio-Geräte mit aufgelistet. Im Regelfall sollte je nach vorhandenen internen und externen Midi- und Audiogeräten in den jeweiligen "midi" Zeilen der Liste die Geräte/Treibernamen aufgelistet sein. Prüfe hier, ob Dein KORG Modell auch als Midi-Geräte-Eintrag in einer der ersten 10 Zeilen aufgeführt ist. Falls nicht, so klicke auf das kleine Pfeilsymbol links neben der Zeile "midi-9" um die Darstellung der Listeneinträge ggf. zu erweitern.

Sollte mein Vedacht zutreffen, so gehe ich davon aus, daß sich Deine KORG-USB-Midi-Hardware nicht unter den ersten 10 Midi-Einträgen befindet.

Um das Problem dann zu beheben, mußt Du die Geräteliste in der Windows Registry bereinigen. Hierzu klickst Du im geöffneten Fenster des KORG Tools "Uninstall Korg USB Midi Device" den Button OPTION an und entfernst den Haken in der Zeile "Delete only Korg USB Midi Device". Quittiere die veränderte Einstellung über den Button OK um wieder zurück in die Listenanzeige zu gelangen.

Entferne dann bis auf die USB-Maus und USB-Tastatur (falls verwendet) alle Midi- und Audio USB Geräte an den USB-Ports des Computers. Es können über das KORG Tool aus der Liste nur die Geräte entfernt werden, die nicht aktiv mit dem Computer verbunden sind. Bitte entferne auch die USB Verbindungen zu den KORG USB-Midi-Geräten!

Setze anschließend bei allen Einträgen, die in schwarzer Schrift im Fenster des "Uninstall Tools" erscheinen (also nicht ausgegraut sind) einen Haken. Dies gilt auch für die Einträge größer 10 und ebenso für die KORG Einträge Deiner KORG Gerät(e).

Anschließend starte das Löschen der Einträge über den Button NEXT / OK und bestätige noch die Sicherheitsmeldung positiv. Wenn das KORG Tool die Einträge aus der Windows Registry entfernt hat, so erscheint im KORG Fenster des Tools der Button FINISH. Darüber beendest Du den Vorgang. Das Fenster schließt daraufhin automatisch.

Verbinde nun Deine KORG USB Hardware erneut mit einem USB-Port Deines Rechners. Bitte verbinde nicht gleichzeitig mehrere USB MIDI Geräte, sondern immer nur eins nach dem anderen.

Daraufhin sollte dann die Windows Hardware-Erkennung starten. Warte ab, bis die Hardware-Erkennung von Windows beendet ist.

Führe dann einen Neustart des Computers durch und starte nach dem Neustart noch einmal das KORG Tool "Uninstall KORG USB MIDI Device". Prüfe jetzt, ob das KORG USB Gerät namentlich in der Liste unter den ersten 10 Einträgen "midi-0 bis midi-9" mit dem Hinweis <Connected> angezeigt wird. Wenn ja, so ist das Problem behoben, wovon im vorliegenden Fall ausgegangen werden darf.

Du kannst dann das Fenster des KORG Tools wieder schließen und Deine Midi-Applikation (z.B. zum Test den KORG KONTROL EDITOR) starten. Das KORG USB Midi Gerät sollte nun in den Geräteeinstellungen der Midi Anwendung als Midi Ein- und Ausgabegerät zur Auswahl bereitstehen. Wird das KORG USB Gerät in der Midi Anwendung als Midi Ein- und Ausgabegerät verwendet, so sollte eine bidirektionale Midi-Datenübertragung zwischen dem Computer und der KORG USB Midi Schnittstelle Deiner KORG Hardware gewährleistet sein.

Bei weiteren Rückfragen wäre es hilfreich, wenn Du auf Basis der hier von mir aufgeführten Hinweise ggf. Screenshots mit den entsprechenden Fensterinhalten in einem neuen Posting mit anhängst und bei Bedarf auch noch ergänzende Angaben dazu machst.

Ich hoffe ansonsten, daß meine Hinweise Dir weiterhelfen konnten und ggf. auch das Problem gelöst werden konnte. In jedem Falle freue ich mich über ein kurzes Feedback.

Gruss

Alex
Aw: Kommunikationsproblem mit nanoPAD2 + nanoKONTRL2 [Beitrag #62356 ist eine Antwort auf Beitrag #62353] Do, 06 Juli 2017 18:57 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Flyer ist gerade offline  Flyer
Beiträge: 3
Registriert: Juli 2017
Newbie-Member
Lieber Alex,
danke erstmal, für deine Bemühungen. Ich werde leider heute nicht mehr dazu kommen, mich weiter mit dem Problem auseinander zu setzen.

Nur soviel erstmal:

Der aktuellste Windows 10 Treiber von Korg (DrvTools_1_15_r20e.exe) und der Kontrol-Editor wurden von mir schon mehrfach erfolglos installiert.

Kein Pfeil neben midi9, ansonsten nur drei Einträge in Port0 - 2, der Rest ist leer.
0 = M-Audio delta Audiophile
1 = Intel(R) Display-Audio
2 = Intel WiDi Audio device

nanoKONTROL2 u. nanoPAD2 erscheinen im Geräte-Manager.

Nach Uninstall im Korg USB Midi Device (wie von die vorgeschlagen) u. erneuter Verbindung des nanoKONTROL erfolgt keine Hardwarerkennung durch Windows. Dafür ist sofort im Gerätemanager wieder der entsprechende Eintrag als Audio, Video, Gamecontroler. Im Uninstall Utility habe ich jetzt auf midi2 den Eintrag: "Corrupted (Korg nanoKONTROL2)" - das war schon mehrfach nach Neuinstallation so.

Auch im Kontrol Editor erschien bisher immer (beim nanoPAD) der Hinweis "Disconnected MIDI-Device". Beim nanoKONTROL ist die Status-Anzeige so schnell weg, dass ich ich nicht mitbekomme, was er mir sagen will.

Ich werde, sobald ich dazu komme, noch entsprechende Screenshots und ergänzende Angaben machen.

Bis dahin liebe Grüße - Dieter
Aw: Kommunikationsproblem mit nanoPAD2 + nanoKONTRL2 [Beitrag #62367 ist eine Antwort auf Beitrag #62356] So, 09 Juli 2017 19:34 Zum vorherigen Beitrag gehen
Flyer ist gerade offline  Flyer
Beiträge: 3
Registriert: Juli 2017
Newbie-Member
Hallo Alex,
habe jetzt mal einen Screenshot mit (hoffentlich) allen relevanten Infos zum Problem erstellt:

index.php?t=getfile&id=2022&private=0

Als Channel-Controler in Cubase EL9 (mackie-modus) funktioniert nanocontrol allerdings, aber nur eingeschränkt (ch.fader, pan, transport, rec., mute etc.)

Auf meinem Laptop (ebenfalls win10/64bit)verlief die Installation dagegen reibungs-/fehlerlos. Verbindung war korrekt u. auch der Editor lief, wie er soll.

Ich hoffe, du kannst mit den Infos was anfangen u. mir Hinweise geben, wo ich den Fehler zu suchen u. zu korrigieren habe.

Bis dahin LG Dieter
  Zur Baumansicht dieses Themas wechseln Ein neues Thema erstellen Antwort abschicken
Vorheriges Thema: Korg Taktile 25
Nächstes Thema: Musik life mit im PC hinterlegtem .sf2 Soundfonds hören
Gehe zum Forum:
  

-=] Zurück zum Anfang [=-
[ Themen als Syndikate anderen Seiten zur Verfügung stellen (XML) ] [ RSS ] [ PDF ]

aktuelle Zeit: Mi Nov 13 15:20:13 CET 2019