KORG FORUM


Startseite » Korg » KORG PC/MAC Tools » Korg microkontrol funktioniert nicht richtig
Anzeigen: Heutige Beiträge :: Abstimmungen anzeigen :: Beitragsnavigator
Zur Baumansicht dieses Themas wechseln Ein neues Thema erstellen Antwort abschicken
icon9.gif  Korg microkontrol funktioniert nicht richtig [Beitrag #26027] Mi, 26 November 2008 09:21 Zum nächsten Beitrag gehen
Abaton ist gerade offline  Abaton
Beiträge: 2
Registriert: November 2008
Newbie-Member
Hallo, ich habe mir bei E-bay ein Korg Microkontrol gekauft.
Als es dann endlich angekommen war, habe ich es an den computer gesteckt (per usb, habe es dan auch mit Netzteil versucht),
Aber es passiert nicht viel.
Nur das Haupt- display leuchtet, zeigt aber nichts an.
Da habe ich mir noch nicht so viel dabei gedacht und erst mal die Treiber usw installiert.

Als ich dan verschiedene Musikprogramme ansteuern wollte gingen nur
die 2 Tasten ganz links und ein paar Regler gingen sporadisch.

habe dann versucht das Firmware Update zu installieren, ging aber auch nicht.
Re: Korg microkontrol funktioniert nicht richtig [Beitrag #26068 ist eine Antwort auf Beitrag #26027] Do, 27 November 2008 03:50 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Alex@KORG ist gerade offline  Alex@KORG
Beiträge: 2925
Registriert: November 2006
Ort: Marburg
Master of Music-Member
Hallo,

Korrekterweise solltest Du in Verbindung mit einem Rechner Dein KORG microKONTROL in der Schalterstellung USB betreiben. Angaben zum verwendeten System (PC oder MAC) wären bei solchen Anfragen auch hilfreich! Rolling Eyes

Falls Du ein PC-USER bist, überprüfe bitte die folgenden Hinweise. Wenn Du dann sicher bist, daß immer noch Funktionsstörungen auftreten poste dies erneut hier.

Bitte installiere das KORG USB-MIDI-TREIBER Tool mit der Bezeichnung "DrvTools_e.exe". Du findest dies auf der mitgelieferten CD-ROM, oder besser noch als aktuellen Download in der Version V1.11 (Vista32 kompatibel). Nach der Installation bitte über das Startmenü (Windows System) auf alle Programme wechseln und dort in dem neu angelegten KORG Ordner das Programm "Install KORG USB Midi Device" starten. Dabei sollte das KORG Gerät über USB verbunden sein und auch eingeschaltet sein.

Ein Fehler kann auf die Tatsache zurückzuführen sein, daß bei dem Erstanschluß von Windows XP im Gerätemanager unter Audio-Video-Gamecontroller ein Treiber mit dem Namen USB-Audiogerät für das KORG Gerät installiert wurde. Dieser muß durch den originalen KORG Midi Treiber ersetzt werden. Die Aufgabe übernimmt automatisch das o.g. Tool.

In wenigen Ausnahmefällen kann es tatsächlich zusätzlich unter Windows zu Problemen mit der Funktionalität des original KORG Gerätetreibers kommen. Es betrifft die sogenannte 10er Regel. Dies kann in den meisten Fällen auch schnell erkannt werden, wenn man nach der KORG Treiberinstallation den KORG Eintrag im Gerätemanager öffnet und auf "Eigenschaften" des Treiber klickt. Dort könnte dann erscheinen "Gerät betriebsbereit aber nicht funktionstüchtig"! (muß aber nicht zwingend sein)
Sollte dies der Fall sein, so hat der User in der Vergangenheit viele MIDI Geräte mit dem Rechner verbunden. Selbst wenn er die Treiber ordnungsgemäß deinstalliert hat, so bleiben die Einträge in der Windows REGISTRY erhalten und blockiern alle neu installierten MIDI-Treiber ab dem 10ten Treiber. Abhilfe schafft hier nur das manuelle löschen dieser Einträge in der REGISTRY. Folgende Schritte sind unter Windows hierzu notwendig.

________________________________

START

Ausführen

Eingabezeile = REGEDIT

Verzeichnis "HKEY LOCAL MACHINE" öffnen

Unterverzeichnis "SOFTWARE" öffnen

Unterverzeichnis "MICROSOFT" öffnen

Unterverzeichnis "WINDOWS NT" öffnen

Verzeichnis "CURRENT VERSION" öffnen

Unterverzeichnis "DRIVERS32" öffnen

jetzt im rechten Fenster die Einträge mit dem Namen "midi - midi1 etc" suchen und nicht verwendete Einträge mit der Entfernungstaste einfach löschen.

Abschließend den Windows Registrierungseditor einfach schließen und NEUSTARTEN - das wars!

_________________________________


Ist die Installation des KORG MIDI Treibers dann letztendlich erfolgreich durchgeführt und achtet der Anwender außerdem darauf, daß ein qualitativ gutes USB Kabel, mit einer Maximallänge von 2 Metern eingesetzt ist, sollte unter den gängigen Applikationen, der KORG Software-Editor auch als VST-PlugIN und Stand Alone funktionieren.

Abschließend kann ich Dir nur versichern, daß die KORG Software in Verbindung mit der KORG Hardware auf allen gängigen Plattformen unter MAC - INTEL MAC - Windows PC XP und VISTA32 reibungslos arbeitet.

Gruss

Alex
Re: Korg microkontrol funktioniert nicht richtig [Beitrag #26148 ist eine Antwort auf Beitrag #26027] Sa, 29 November 2008 02:27 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Abaton ist gerade offline  Abaton
Beiträge: 2
Registriert: November 2008
Newbie-Member
Laughing

Problem gelöst, ich habe das ding aufgeschraubt, dan habe ich schon auf einen Blick gesehen was los war.
Beide Flachkabel hatten sich gelöst.
...Angesteckt... läuft einwandfrei.

Mal ehrlich, das ding sieht von innen schon ganz schön windig aus.
Trotzdem ein tolles Gerät.
Re: Korg microkontrol funktioniert nicht richtig [Beitrag #26253 ist eine Antwort auf Beitrag #26027] Di, 02 Dezember 2008 02:48 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Dadatech
Beiträge: 3
Registriert: Dezember 2008
Newbie-Member
Hallo

ich habe ein ähnliches Problem. Ich besitze seit kurzem das MicroKontrol und möchte es mit dem mitgelieferten Ableton Lite Korg Edition auf einem Widows 32 Rechner für Livesets benutzen. Die neusten Treiber sind installiert und ich habe bisher auch nur einen anderen Midicontroller auf diesem System verwendet. Die Klaviatur funktionier bestens im USB-Betrieb aber leider kann ich weder den Fadern noch den Drehreglern oder den Pads Funktionen zuweisen. Ich hab das MicroKontrol an dem Rechner eines Freundes ausprobiert (natürlich nach dem ich die Treiber installiert habe) der FL Studio 7 benutzt und da war es überhaupt kein Problem. Vielleicht bin ich auch nicht ganz im Bilde wie die Zuweisung unter Ableton funktioniert, aber normalerweise müsste es doch genügen die MIDI-Taste rechts oben anzuklicken, so dass alle Funktionen lila hinterlegt sind, dann auf einen Regler klicken und dann den Fader bewegen auf den ich diese Funktion legen möchte. Leider hat das überhaupt keinen Effekt auf das Programm. Es hat auch nichts gebracht das MicroKotrol in der mitgelieferten LIVE Scene laufen zu lassen in der ja zumindest die wichtigstens Funktionen von LIVE schon vorbelegt sein müssten.
Die Tatsache, dass das Keyboard unter FL Studio tadelos funktioniert könnte auch bedeuten, dass es an Ableton liegt, trotzdem wende ich mich zuerst an euch, weil ich ja die von Korg mitgelieferte Korg Edition von Live benutze und es in euren Test im Vorfeld ja offensichtlich funktioniert hat das MicroKontrol einschränkungsfrei mit Ableton zu benutzen (sonst gäbe es keine vorgefertigten Scenes). Ein kostenloses Update von LIVE 6 auf LIVE 7 kommt für mich nicht in Frage, weil ich auch Filme vertone und diese Funktion in Live 7 lite nicht implementiert ist (mal abgesehen davon, das das wohl auch nichts ändern würde).
Ich bin langsam ziemlich frustriert, schliesslich kostet euer MicroKontrol einen Haufen Geld im Vergleich zu anderen Controllern und ich dacht, dass ich solchen Kinderkrankheiten aus dem Weg gehen kann wenn ich mal etwas Geld in die Hand nehme und mir etwas "Vernünftiges" kaufe. Eigentlich erwarte ich von einem Midikeyboard, dass wenn ich schon Treiber installieren muss, die Kiste funktioniert sobald ich es eingschalten und dannach mein DAW gestarte habe. Es gibt auch Plug&Play Keyboards, und das muss mir erst noch jemand erklären warum ich mir die Mühe mit den Treibern machen soll wenn es dann doch nicht funktioniert.
Vermutlich hab ich es gar selbst verKORGst, aber ich hoffe die Profis von Korg könne mir helfen mein Problem zu beheben ohne dass ich damit mühsam in weiteren Foren anklopfen muss. Bis jetz findet man noch recht wenig wenn man in Google "Korg + MicroKontrol + Probleme" eintippt, weshalb ich das Problem auch noch nicht selbst lösen konnte.

Schonmal Vorschuss-Danke,

Flo
Re: Korg microkontrol funktioniert nicht richtig [Beitrag #26266 ist eine Antwort auf Beitrag #26253] Di, 02 Dezember 2008 19:43 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Alex@KORG ist gerade offline  Alex@KORG
Beiträge: 2925
Registriert: November 2006
Ort: Marburg
Master of Music-Member
Dadatech schrieb am Di, 02 Dezember 2008 01:48



........Vermutlich hab ich es gar selbst verKORGst, aber ich hoffe die Profis von Korg könne mir helfen mein Problem zu beheben ohne dass ich damit mühsam in weiteren Foren anklopfen muss. Bis jetz findet man noch recht wenig wenn man in Google "Korg + MicroKontrol + Probleme" eintippt, weshalb ich das Problem auch noch nicht selbst lösen konnte.

Schonmal Vorschuss-Danke,

Flo



Hallo Flo,

Das sind doch schon einmal gute Infos, die Du hier hinterlegt hast. Man kann also erst einmal davon ausgehen, daß Dein KORG microKONTROL in Takt ist.

In Ableton hast Du eine LEARN Funktion. Diese kann aber nur funktionieren, wenn Du in den MIDI-Einstellungen Deiner DAW auch das KORG microKONTROL als MIDI-Device zugeordnet hast. Vielleicht liegt dort Dein Problem?

Kannst Du denn überhaupt eine Funktion (Controller oder NOTE Events)in Ableton von Deinem KORG microKONTROL empfangen?

Was für ein Windows System verwendest DU (XP / VISTA)?

Wird das microKONTROL im Gerätemanager Deines Windows System als MIDI-DEVICE fehlerfrei angezeigt?

Bitte dies zu überprüfen und ggf. nochmal hier zu posten - Danke!

Gruss

Alex
Re: Korg microkontrol funktioniert nicht richtig [Beitrag #26280 ist eine Antwort auf Beitrag #26266] Mi, 03 Dezember 2008 16:28 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Dadatech
Beiträge: 3
Registriert: Dezember 2008
Newbie-Member
Hi Alex,

Ich weiss es war ein langer Text den ich dir da zugemutet habe, desshalb zitiere ich die Quintessenz meines Problems einfach nochmal aus meinem Beitrag:

"Die Klaviatur funktionier bestens im USB-Betrieb aber leider kann ich weder den Fadern noch den Drehreglern oder den Pads Funktionen zuweisen."

Ergo empfängt Ableton MIDIdaten, aber setzt eben NUR Note-Events um.
Die MIDI-Empfangsanzeige leuchtet auch auf, sowohl bei Notenbefehlen als auch bei Betätigung der Fadern, Pads, und Drehregler!! Das bedeutet Ableton empfängt eigentlich verwertbare Midibefehle. Trotzdem tut sich nichts bei den Pads, Fadern und Potis wenn ich sie zuweisen will!

Ich benutze XP 32 mit SP3. Wie gesagt sind die aktuellen Treiber installiert. Das Keyboard, und da hast du recht, ist nicht kaputt, weil es unter FL Studio funktioniert.
Abletons MIDI-Learnfunktion ist auch nicht so kompliziert, dass ich das nicht verstehen würde - daran liegt es also nicht.

Im Gerätemanager wird das MicroKontrol unter AUDIO, VIDEO UND GAMECONTROLLER als USB AUDIO-Gerät im Status "Betriebsbereit" angezeigt [Pfad 0 (microKONTROL)]. Unter "Eigenschaften des USB-Audiogeräts" steht, dass sowohl für das USB-Audiogeräte wie auch für das WDM-MIDI-Gerät die Treiber aktiviert und funktionstüchtig sind.

Ich vermute das Problem liegt bei der Voreinstellung von Ableton.
Selbstverständlich habe ich in den Voreinstellungen das MicroKontrol als Bedienoberfläche angegeben.
Als "Eingang" steht im Dropdownmenü das MicroKontrol aber nicht als auswählbare Option zur verfügung. Genausowenig als "Ausgang".
Für den Eingang gibt es nur die Optionen USB-Audiogerät(1), USB-Audiogerät(2), USB-Audiogerät(3) (also vermutlich USB-Tastatur und USB-Maus. Nr. 3 könnte das MicroKontrol sein, weil sonst ausser einer externen, abgeschalteten Festplatte keine USB Geräte angeschlossen sind).
Für den Ausgang gibt es nur die Optionen USB-AudioGerät 1 und 2 und den Microsoft GS Wavetable Synth (also kein USB Audiogerät(3) wie im "Eingang", ich schätze weil ich "Fernsteuerung" ausgeschalten habe (siehe unten).
Dem Screenshot des Ableton-Manuals zu Thema "FERNSTEUERUNG ÜBER MIDI UND RECHNERTASTATUR" entnehme ich, dass es aber möglich sein sollte in den Ein-und Ausgangs-Dropdownoptionen auch das MicroKontrol direkt auszuwählen.
Muss ich hier noch zusätzlich auf "Senden" klicken? Ich denke,eigentlich nicht, die Funktion ist ja nur dazu da Presets zu übertragen und das brauch ich nicht, weil ich meinen Zuweisungen selbst machen möchte, oder?

Frage: Wie müssen denn die Midiports konfiguriert sein? Im Moment sind alle drei Inputs und Outputs auf "An", alle "Sync" auf an und alle "Fernsteuerungen" auf "Aus" weil das MicroKontrol ja keine Motorfader o.ä. besitzt und desshalb keine MIDI-Events von Ableton empfangen muss um zu funktionieren. Ist das richtig so?

Ich hoffe das waren jetzt genug Informationen um euch bzw dir einen Ferndiagnose zu erlauben.


Liebe Grüsse,

Flo




Re: Korg microkontrol funktioniert nicht richtig [Beitrag #26290 ist eine Antwort auf Beitrag #26280] Do, 04 Dezember 2008 05:40 Zum vorherigen Beitrag gehenZum nächsten Beitrag gehen
Alex@KORG ist gerade offline  Alex@KORG
Beiträge: 2925
Registriert: November 2006
Ort: Marburg
Master of Music-Member
@flo,

ich muß Dir leider bescheinigen, daß Du meinen vorletzten Beitrag nicht aufmerksam genug gelesen hast!!!

Du hättest Dir dadurch viel Arbeit ersparen können!

hier der Auszug aus meinem Hinweis!

"...Ein Fehler kann auf die Tatsache zurückzuführen sein, daß bei dem Erstanschluß von Windows XP im Gerätemanager unter Audio-Video-Gamecontroller ein Treiber mit dem Namen USB-Audiogerät für das KORG Gerät installiert wurde. Dieser muß durch den originalen KORG Midi Treiber ersetzt werden. Die Aufgabe übernimmt automatisch das o.g. Tool."

Genau dies ist bei Dir der Fall. Aus diesem Grunde wird Dein KORG Gerät auch nicht als microKONTROL in Ableton angezeigt und es können daher weder SysEx Daten vom mitgelieferten Editor übertragen werden, noch Deine Midi-Controller Funktionen.

Starte einfach nur bei angeschlossenem microKONTROL über START -> Alle Programme -> KORG -> KORG USB Midi Drvier -> die Routine "INSTALL KORG USB MIDI DEVICE und folge den Anweisungen, nachdem Dein angeschlossenes microKONTROL vom KORG Installationstool erkannt worden ist.

Du wirst dann feststellen, daß im Gerätemanager das USB-Audiogerät verschwindet und statt dessen der Eintrag KORG microKONTROL erscheint.

Danach wirst Du auch in Ableton in der Midi-Konfiguration das KORG Device angezeigt und auswählen können.

Auch Dein KORG Software-Editor wird problemlos mit Deinem microKONTROL kommunizieren können.

Verwende aber bitte immer die aktuellen KORG Treiber- und Editorversionen.

Gruss

Alex
Re: Korg microkontrol funktioniert nicht richtig [Beitrag #26413 ist eine Antwort auf Beitrag #26027] Di, 09 Dezember 2008 20:44 Zum vorherigen Beitrag gehen
Dadatech
Beiträge: 3
Registriert: Dezember 2008
Newbie-Member
Danke dir Alex,

hat funktioniert.

bis denne,

Flo
  Zur Baumansicht dieses Themas wechseln Ein neues Thema erstellen Antwort abschicken
Vorheriges Thema: KLC und LOGIC 8
Nächstes Thema: Nanokontrol erkennt keine CC_controllerdaten?
Gehe zum Forum:
  

-=] Zurück zum Anfang [=-
[ Themen als Syndikate anderen Seiten zur Verfügung stellen (XML) ] [ RSS ] [ PDF ]

aktuelle Zeit: Do Okt 22 23:07:59 CEST 2020